// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ism)<!--\sLOCALE\sru\s-->(.*?)<!--\s\/LOCALE\s-->").unwrap();
let string = "<!-- LOCALE uk -->
<h2 class=\"\">Required Information UK</h2>
<!-- /LOCALE -->
<!-- LOCALE uk --><h2 class=\"\">Required Information UK</h2><!-- /LOCALE -->
<!-- LOCALE ru -->
<h2 class=\"\">Required Information RU</h2>
<!-- /LOCALE -->";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}