$re = '/<!--\sLOCALE\sru\s-->(.*?)<!--\s\/LOCALE\s-->/ism';
$str = '<!-- LOCALE uk -->
<h2 class="">Required Information UK</h2>
<!-- /LOCALE -->
<!-- LOCALE uk --><h2 class="">Required Information UK</h2><!-- /LOCALE -->
<!-- LOCALE ru -->
<h2 class="">Required Information RU</h2>
<!-- /LOCALE -->';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);