using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<!--\sLOCALE\sru\s-->(.*?)<!--\s\/LOCALE\s-->";
string input = @"<!-- LOCALE uk -->
<h2 class="">Required Information UK</h2>
<!-- /LOCALE -->
<!-- LOCALE uk --><h2 class="">Required Information UK</h2><!-- /LOCALE -->
<!-- LOCALE ru -->
<h2 class="">Required Information RU</h2>
<!-- /LOCALE -->";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline | RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}