re = /<!--\sLOCALE\sru\s-->(.*?)<!--\s\/LOCALE\s-->/im
str = '<!-- LOCALE uk -->
<h2 class="">Required Information UK</h2>
<!-- /LOCALE -->
<!-- LOCALE uk --><h2 class="">Required Information UK</h2><!-- /LOCALE -->
<!-- LOCALE ru -->
<h2 class="">Required Information RU</h2>
<!-- /LOCALE -->'
# Print the match result
str.match(re) do |match|
puts match.to_s
end