package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ism)<!--\sLOCALE\sru\s-->(.*?)<!--\s\/LOCALE\s-->`)
var str = `<!-- LOCALE uk -->
<h2 class="">Required Information UK</h2>
<!-- /LOCALE -->
<!-- LOCALE uk --><h2 class="">Required Information UK</h2><!-- /LOCALE -->
<!-- LOCALE ru -->
<h2 class="">Required Information RU</h2>
<!-- /LOCALE -->`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}