#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""personaname":\s"([^"]+)""
Local $sString = "{" & @CRLF & _
" "response": {" & @CRLF & _
" "players": [" & @CRLF & _
" {" & @CRLF & _
" "profilestate": 1," & @CRLF & _
" "personaname": "Furious Skunk"," & @CRLF & _
" "personastate": 1," & @CRLF & _
" "primaryclanid": "103582221429719132"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "profilestate": 1," & @CRLF & _
" "personaname": "Tom MLG 1337"," & @CRLF & _
" "personastate": 1," & @CRLF & _
" "primaryclanid": "103582793333284766"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "profilestate": 1," & @CRLF & _
" "personaname": "Mista Bombastic, reggae fantastic"," & @CRLF & _
" "personastate": 1," & @CRLF & _
" "primaryclanid": "101182741435284766"" & @CRLF & _
" }" & @CRLF & _
" ]" & @CRLF & _
" " & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")