import re
regex = re.compile(r"\"personaname\":\s\"([^\"]+)\"")
test_str = ("{\n"
" \"response\": {\n"
" \"players\": [\n"
" {\n"
" \"profilestate\": 1,\n"
" \"personaname\": \"Furious Skunk\",\n"
" \"personastate\": 1,\n"
" \"primaryclanid\": \"103582221429719132\"\n"
" },\n"
" {\n"
" \"profilestate\": 1,\n"
" \"personaname\": \"Tom MLG 1337\",\n"
" \"personastate\": 1,\n"
" \"primaryclanid\": \"103582793333284766\"\n"
" },\n"
" {\n"
" \"profilestate\": 1,\n"
" \"personaname\": \"Mista Bombastic, reggae fantastic\",\n"
" \"personastate\": 1,\n"
" \"primaryclanid\": \"101182741435284766\"\n"
" }\n"
" ]\n"
" \n"
" }\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")