// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""personaname":\s"([^"]+)""#).unwrap();
let string = "{
\"response\": {
\"players\": [
{
\"profilestate\": 1,
\"personaname\": \"Furious Skunk\",
\"personastate\": 1,
\"primaryclanid\": \"103582221429719132\"
},
{
\"profilestate\": 1,
\"personaname\": \"Tom MLG 1337\",
\"personastate\": 1,
\"primaryclanid\": \"103582793333284766\"
},
{
\"profilestate\": 1,
\"personaname\": \"Mista Bombastic, reggae fantastic\",
\"personastate\": 1,
\"primaryclanid\": \"101182741435284766\"
}
]
}
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}