import Foundation
let pattern = #""personaname":\s"([^"]+)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{
"response": {
"players": [
{
"profilestate": 1,
"personaname": "Furious Skunk",
"personastate": 1,
"primaryclanid": "103582221429719132"
},
{
"profilestate": 1,
"personaname": "Tom MLG 1337",
"personastate": 1,
"primaryclanid": "103582793333284766"
},
{
"profilestate": 1,
"personaname": "Mista Bombastic, reggae fantastic",
"personastate": 1,
"primaryclanid": "101182741435284766"
}
]
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)