package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"personaname":\s"([^"]+)"`)
var str = `{
"response": {
"players": [
{
"profilestate": 1,
"personaname": "Furious Skunk",
"personastate": 1,
"primaryclanid": "103582221429719132"
},
{
"profilestate": 1,
"personaname": "Tom MLG 1337",
"personastate": 1,
"primaryclanid": "103582793333284766"
},
{
"profilestate": 1,
"personaname": "Mista Bombastic, reggae fantastic",
"personastate": 1,
"primaryclanid": "101182741435284766"
}
]
}
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}