$re = '/"personaname":\s"([^"]+)"/';
$str = '{
"response": {
"players": [
{
"profilestate": 1,
"personaname": "Furious Skunk",
"personastate": 1,
"primaryclanid": "103582221429719132"
},
{
"profilestate": 1,
"personaname": "Tom MLG 1337",
"personastate": 1,
"primaryclanid": "103582793333284766"
},
{
"profilestate": 1,
"personaname": "Mista Bombastic, reggae fantastic",
"personastate": 1,
"primaryclanid": "101182741435284766"
}
]
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);