use strict;
my $str = '{
"response": {
"players": [
{
"profilestate": 1,
"personaname": "Furious Skunk",
"personastate": 1,
"primaryclanid": "103582221429719132"
},
{
"profilestate": 1,
"personaname": "Tom MLG 1337",
"personastate": 1,
"primaryclanid": "103582793333284766"
},
{
"profilestate": 1,
"personaname": "Mista Bombastic, reggae fantastic",
"personastate": 1,
"primaryclanid": "101182741435284766"
}
]
}
}';
my $regex = qr/"personaname":\s"([^"]+)"/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}