const regex = /"personaname":\s"([^"]+)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"personaname":\\s"([^"]+)"', 'g')
const str = `{
"response": {
"players": [
{
"profilestate": 1,
"personaname": "Furious Skunk",
"personastate": 1,
"primaryclanid": "103582221429719132"
},
{
"profilestate": 1,
"personaname": "Tom MLG 1337",
"personastate": 1,
"primaryclanid": "103582793333284766"
},
{
"profilestate": 1,
"personaname": "Mista Bombastic, reggae fantastic",
"personastate": 1,
"primaryclanid": "101182741435284766"
}
]
}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}