# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[0-9]{3}(\-|\ |\ )?[0-9]{3}(\-|\--|\ )?-?[0-9]{4}//gm;t' <<< "998-999-9999
788 566-9876
763 535 6788
452456-7666
6765267892"