using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]{3}(\-|\ |\ )?[0-9]{3}(\-|\--|\ )?-?[0-9]{4}";
string substitution = @"";
string input = @"998-999-9999
788 566-9876
763 535 6788
452456-7666
6765267892";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}