package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]{3}(\-|\ |\ )?[0-9]{3}(\-|\--|\ )?-?[0-9]{4}`)
var str = `998-999-9999
788 566-9876
763 535 6788
452456-7666
6765267892`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}