#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[0-9]{3}(\-|\ |\ )?[0-9]{3}(\-|\--|\ )?-?[0-9]{4}"
Local $sString = "998-999-9999" & @CRLF & _
"788 566-9876" & @CRLF & _
"763 535 6788" & @CRLF & _
"452456-7666" & @CRLF & _
"6765267892"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)