re = /[0-9]{3}(\-|\ |\ )?[0-9]{3}(\-|\--|\ )?-?[0-9]{4}/m
str = '998-999-9999
788 566-9876
763 535 6788
452456-7666
6765267892'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result