import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]{3}(\\-|\\ |\\ )?[0-9]{3}(\\-|\\--|\\ )?-?[0-9]{4}";
final String string = "998-999-9999\n"
+ "788 566-9876\n"
+ "763 535 6788\n"
+ "452456-7666\n"
+ "6765267892";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}