const regex = /[0-9]{3}(\-|\ |\ )?[0-9]{3}(\-|\--|\ )?-?[0-9]{4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]{3}(\\-|\\ |\\ )?[0-9]{3}(\\-|\\--|\\ )?-?[0-9]{4}', 'gm')
const str = `998-999-9999
788 566-9876
763 535 6788
452456-7666
6765267892`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);