use strict;
my $str = '998-999-9999
788 566-9876
763 535 6788
452456-7666
6765267892';
my $regex = qr/[0-9]{3}(\-|\ |\ )?[0-9]{3}(\-|\--|\ )?-?[0-9]{4}/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";