$re = '/[0-9]{3}(\-|\ |\ )?[0-9]{3}(\-|\--|\ )?-?[0-9]{4}/m';
$str = '998-999-9999
788 566-9876
763 535 6788
452456-7666
6765267892';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;