# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\/foo\\/\K([0-9]+)/4321/gm;t' <<< "http://images.example.com/foo/1234/bar/foobar"