const regex = /\/foo\/\K([0-9]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/foo\\\/\\K([0-9]+)', 'gm')
const str = `http://images.example.com/foo/1234/bar/foobar`;
const subst = `4321`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);