using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/foo\/\K([0-9]+)";
string substitution = @"4321";
string input = @"http://images.example.com/foo/1234/bar/foobar";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}