use strict;
my $str = 'http://images.example.com/foo/1234/bar/foobar';
my $regex = qr/\/foo\/\K([0-9]+)/mp;
my $subst = '4321';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";