import Foundation
let pattern = #"\/foo\/\K([0-9]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"http://images.example.com/foo/1234/bar/foobar"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"4321"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)