$re = '/\/foo\/\K([0-9]+)/m';
$str = 'http://images.example.com/foo/1234/bar/foobar';
$subst = "4321";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;