re = /\/foo\/\K([0-9]+)/m
str = 'http://images.example.com/foo/1234/bar/foobar'
subst = '4321'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result