import re
regex = re.compile(r"\/foo\/\K([0-9]+)", flags=re.MULTILINE)
test_str = "http://images.example.com/foo/1234/bar/foobar"
subst = "4321"
result = regex.sub(subst, test_str)
if result:
print(result)