#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\/foo\/\K([0-9]+)"
Local $sString = "http://images.example.com/foo/1234/bar/foobar"
Local $sSubst = "4321"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)