#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?:\d\.)?(?:\d{1,3}\.)?\d{1,3},\d{1,2})|(\d)"
Local $sString = "1.000,20" & @CRLF & _
"5.611.000,20" & @CRLF & _
"541.000,00" & @CRLF & _
"10,20" & @CRLF & _
"0" & @CRLF & _
"0,20" & @CRLF & _
"9.999.999,99"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")