$re = '/((?:\d\.)?(?:\d{1,3}\.)?\d{1,3},\d{1,2})|(\d)/';
$str = '1.000,20
5.611.000,20
541.000,00
10,20
0
0,20
9.999.999,99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);