// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((?:\d\.)?(?:\d{1,3}\.)?\d{1,3},\d{1,2})|(\d)").unwrap();
let string = "1.000,20
5.611.000,20
541.000,00
10,20
0
0,20
9.999.999,99";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}