using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\d\.)?(?:\d{1,3}\.)?\d{1,3},\d{1,2})|(\d)";
string input = @"1.000,20
5.611.000,20
541.000,00
10,20
0
0,20
9.999.999,99";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}