import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\\d\\.)?(?:\\d{1,3}\\.)?\\d{1,3},\\d{1,2})|(\\d)";
final String string = "1.000,20\n"
+ "5.611.000,20\n"
+ "541.000,00\n"
+ "10,20\n"
+ "0\n"
+ "0,20\n"
+ "9.999.999,99";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}