use strict;
my $str = '1.000,20
5.611.000,20
541.000,00
10,20
0
0,20
9.999.999,99';
my $regex = qr/((?:\d\.)?(?:\d{1,3}\.)?\d{1,3},\d{1,2})|(\d)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}