import re
regex = re.compile(r"((?:\d\.)?(?:\d{1,3}\.)?\d{1,3},\d{1,2})|(\d)")
test_str = ("1.000,20\n"
"5.611.000,20\n"
"541.000,00\n"
"10,20\n"
"0\n"
"0,20\n"
"9.999.999,99")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")