package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:\d\.)?(?:\d{1,3}\.)?\d{1,3},\d{1,2})|(\d)`)
var str = `1.000,20
5.611.000,20
541.000,00
10,20
0
0,20
9.999.999,99`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}