# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\s)[+-]?\d+(?:.\d)?\d*//g;t' <<< "Current Level: -13.2 db or 14.212 or 3
MH2317.1
2317.1"