using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\s)[+-]?\d+(?:.\d)?\d*";
string substitution = @"";
string input = @"Current Level: -13.2 db or 14.212 or 3
MH2317.1
2317.1";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}