use strict;
my $str = 'Current Level: -13.2 db or 14.212 or 3
MH2317.1
2317.1';
my $regex = qr/(?<=\s)[+-]?\d+(?:.\d)?\d*/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";