import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\s)[+-]?\\d+(?:.\\d)?\\d*";
final String string = "Current Level: -13.2 db or 14.212 or 3\n"
+ "MH2317.1\n"
+ "2317.1";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}