const regex = /(?<=\s)[+-]?\d+(?:.\d)?\d*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\s)[+-]?\\d+(?:.\\d)?\\d*', 'g')
const str = `Current Level: -13.2 db or 14.212 or 3
MH2317.1
2317.1`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);