import Foundation
let pattern = #"(?<=\s)[+-]?\d+(?:.\d)?\d*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Current Level: -13.2 db or 14.212 or 3
MH2317.1
2317.1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)