#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=\s)[+-]?\d+(?:.\d)?\d*"
Local $sString = "Current Level: -13.2 db or 14.212 or 3" & @CRLF & _
"MH2317.1" & @CRLF & _
"2317.1"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)