re = /(?<=\s)[+-]?\d+(?:.\d)?\d*/
str = 'Current Level: -13.2 db or 14.212 or 3
MH2317.1
2317.1'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result