$re = '/(?<=\s)[+-]?\d+(?:.\d)?\d*/';
$str = 'Current Level: -13.2 db or 14.212 or 3
MH2317.1
2317.1';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;