# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/'([^']*(?:''[^']*)*)'/\0/g;t' <<< "'word'''',and''','another'',''word','''test',X,'',FUNCTION('A'' B C D')"