package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`'([^']*(?:''[^']*)*)'`)
var str = `'word'''',and''','another'',''word','''test',X,'',FUNCTION('A'' B C D')`
var substitution = "\0"
fmt.Println(re.ReplaceAllString(str, substitution))
}